<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>

<meta charset="UTF-8" />

<meta name="description" content="Ancient spice has modern benefits By Angela Shelf Medearis &#160; Turmeric has spiced up the news over the past few years. It’s a unique ingredient with an ancient history. Turmeric is thought to have originated in India over 5,000 years ago. It’s also a common ingredient in Chinese medicine and the centerpiece of Ayurveda, a [&#8230;]" />
<meta name="keywords" content="," /><!--End Meta Tags For SEO-->
<meta property="og:title" content="Timeless Turmeric - North Valley Magazine"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://www.northvalleymagazine.com/timeless-turmeric/"/>
<meta property="og:image" content="http://www.northvalleymagazine.com/wp-content/uploads/2018/10/Screen-Shot-2018-10-22-at-2.19.15-PM.png"/>
<meta property="og:description" content="Ancient spice has modern benefits By Angela Shelf Medearis &#160; Turmeric has spiced up the news over the past few years. It’s a unique ingredient with an ancient history. Turmeric is thought to have originated in India over 5,000 years ago. It’s also a common ingredient in Chinese medicine and the centerpiece of Ayurveda, a [&#8230;]"/>
<meta property="og:site_name" content="North Valley Magazine"/>
	<link rel="stylesheet" type="text/css" href="http://www.northvalleymagazine.com/wp-content/themes/goodnews4/style.css" />

 
<link href='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/responsive.css' rel='stylesheet' type='text/css'>
<link href='http://fonts.googleapis.com/css?family=Play:400,700' rel='stylesheet' type='text/css'>
<!-- Custom favicon -->
<link rel="shortcut icon" href="http://www.northvalleymagazine.com/wp-content/uploads/2013/03/n-favicon.png" />

<!-- feeds, pingback -->
  <link rel="alternate" type="application/rss+xml" title="North Valley Magazine RSS Feed" href="http://www.northvalleymagazine.com/feed/" />
  <link rel="pingback" href="http://www.northvalleymagazine.com/xmlrpc.php" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

<!-- This site is optimized with the Yoast SEO plugin v5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Timeless Turmeric - North Valley Magazine</title>
<link rel="canonical" href="http://www.northvalleymagazine.com/timeless-turmeric/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Timeless Turmeric - North Valley Magazine" />
<meta property="og:description" content="Ancient spice has modern benefits By Angela Shelf Medearis &nbsp; Turmeric has spiced up the news over the past few years. It’s a unique ingredient with an ancient history. Turmeric is thought to have originated in India over 5,000 years ago. It’s also a common ingredient in Chinese medicine and the centerpiece of Ayurveda, a &hellip;" />
<meta property="og:url" content="http://www.northvalleymagazine.com/timeless-turmeric/" />
<meta property="og:site_name" content="North Valley Magazine" />
<meta property="article:section" content="Blog" />
<meta property="article:published_time" content="2018-11-25T00:18:38+00:00" />
<meta property="article:modified_time" content="2018-10-23T00:21:46+00:00" />
<meta property="og:updated_time" content="2018-10-23T00:21:46+00:00" />
<meta property="og:image" content="http://www.northvalleymagazine.com/wp-content/uploads/2018/10/Screen-Shot-2018-10-22-at-2.19.15-PM.png" />
<meta property="og:image:width" content="792" />
<meta property="og:image:height" content="527" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="North Valley Magazine &raquo; Timeless Turmeric Comments Feed" href="http://www.northvalleymagazine.com/timeless-turmeric/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.northvalleymagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='options_typography_-css'  href='http://fonts.googleapis.com/css?family=' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_georgia-css'  href='http://fonts.googleapis.com/css?family=georgia' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/builder/js_composer/assets/bootstrap/css/bootstrap.css?ver=3.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/builder/js_composer/assets/css/js_composer_front.css?ver=3.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='DOPTS_JScrollPaneStyle-css'  href='http://www.northvalleymagazine.com/wp-content/plugins/dopts/libraries/gui/css/jquery.jscrollpane.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='DOPTS_ThumbnailScrollerStyle-css'  href='http://www.northvalleymagazine.com/wp-content/plugins/dopts/assets/gui/css/jquery.dop.ThumbnailScroller.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='default-template-css'  href='http://www.northvalleymagazine.com/wp-content/plugins/really-simple-twitter-feed-widget/extension/readygraph/assets/css/default-popup.css?ver=4.9.8' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-66735939-1';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-66735939-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.cycle.all.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.tools.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.cookie.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.jplayer.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/effects.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.tweet.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.prettyPhoto.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.tipsy.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.fitvids.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.li-scroller.1.0.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.9.2/jquery-ui.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/plugins/dopts/assets/js/jquery.dop.ThumbnailScroller.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dfp_ad_object = [{"google_ad_script_name":"google_ad_js","script_name":null,"account_id":"\/6099645\/","asynch":true,"dir_uri":null,"positions":[{"post_id":2939,"title":"NVM-300x250-Top","ad_name":"NVM-300x250-Top","position_tag":"ad_pos_nvm-300x250-top","sizes":[300,250],"out_of_page":true,"targeting":[]},{"post_id":2938,"title":"NVM-300x250-Middle","ad_name":"NVM-300x250-Middle","position_tag":"ad_pos_nvm-300x250-middle","sizes":[300,250],"out_of_page":true,"targeting":[]},{"post_id":2933,"title":"NVM-300x250-Bottom","ad_name":"NVM-300x250-Bottom","position_tag":"ad_pos_nvm-300x250-bottom","sizes":[300,250],"out_of_page":true,"targeting":[]}],"page_targeting":{"Page":["timeless-turmeric"],"Category":["Blog","Dining"],"Tag":""}}];
/* ]]> */
</script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/plugins/dfp-ads/assets/js/google-ads.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/plugins/dfp-ads/assets/js/dfp-ads.min.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='http://www.northvalleymagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.northvalleymagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.northvalleymagazine.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='http://www.northvalleymagazine.com/?p=3429' />
<link rel="alternate" type="application/json+oembed" href="http://www.northvalleymagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.northvalleymagazine.com%2Ftimeless-turmeric%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.northvalleymagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.northvalleymagazine.com%2Ftimeless-turmeric%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.5 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-2 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


    <!--[if lt IE 9]>
<script src="http://ie7-js.googlecode.com/svn/version/2.1(beta4)/IE9.js"></script>
<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

      <script type="text/javascript" src="http://maps.google.com/maps/api/js?sensor=false"></script>
<!-- Place this render call where appropriate -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
 <style type="text/css">
body {
background-repeat:repeat;
background-attachment: scroll;
 
font-size:14px;
font-weight: Normal;
}
a:hover, .cat_article_content .article_read_more, a.nb_recent_more, .tweet_list li a:hover, .news_box .recent_news_content span a:hover, .article_meta a:hover {
color:#3FB8AF;
}

.single_article_content h1 {
font-size:36px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h2 {
font-size:30px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h3 {
font-size:24px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h4 {
font-size:18px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h5 {
font-size:14px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h6 {
font-size:12px;
font-weight: Normal;
font-family:georgia;
}

/*----------------------------------
 *          Main font
 ----------------------------------*/
#navigation ul.nav > li a , .slider_items .slider_caption h2, .slider_items .slider_caption h2 a, .lates_video_news .widget_title, .news_box .news_box_heading h2, .sidebar .widget .widget_title, .sidebar .widget input.sb, #footer .widget .widget_title, .cat_title, .tabbed_widget ul.tabbed_nav li a, .mom_social_counter .sc_item .social_box span, ul#ticker01 li a, #crumbs {
font-family: !important;
}
/*******************************************************************
 *      Colors Start Here 
 *****************************************************************/
/*    Alert Bar   */
.top_alert {
background-repeat:no-repeat;
background-attachment: scroll;
 
}
/*    Topbar & bottombar     */
.top_bar, .top_bar ul.top_nav li ul, .bottom_bar {
background-color:#3FB8AF;
box-shadow: 0 0px 0px 0 #3C4048 inset;
background-repeat:no-repeat;
background-attachment: scroll;
 
}
.top_bar ul.top_nav li a, .bottom_bar a, .bottom_bar p.copyrights {
color:#000000;
}
/*  Header  */
#header {
background-repeat:repeat;
background-attachment: scroll;
 
}

/*      Navigation      */
#navigation .nav_wrap {
background-repeat:repeat;
background-attachment: scroll;
 
}
#navigation ul.nav li:hover > a, #navigation ul.nav > li.current-menu-item > a, #navigation ul.nav > li.current-menu-ancestor > a, #navigation ul.nav li.home:hover > a, #navigation ul.nav > li.home.current-menu-item > a, #navigation ul.nav > li.home.current-menu-ancestor > a {
color:#000000;
}
#navigation ul.nav li:hover > a, #navigation ul.nav > li.current-menu-item > a, #navigation ul.nav > li.current-menu-ancestor > a, #navigation ul.nav li.home:hover > a, #navigation ul.nav > li.home.current-menu-item > a, #navigation ul.nav > li.home.current-menu-ancestor > a,  #navigation ul.nav li ul li {
background-color:#3FB8AF;
}
#navigation ul.nav li ul li a:hover {
color:;
background-repeat:repeat;
background-attachment: scroll;
 
}
/*     Feature      */
/*     Widgets  */
.sidebar .widget, .lates_video_news, .news_box, .cat_article, .ticker_widget, .news_boxes_tabs {
}
.sidebar .widget .widget_title, .lates_video_news .widget_title, .news_boxes_tabs ul.custom_tabs {
}
/*  NewsBox */

/* News Ticker */
.ticker_widget {
background-color:#3fb8af;
}
ul#ticker01 li a {
color:#40454d;
font-size:14px;
font-weight: Normal;
}
ul#ticker01 li a:hover {
    color:#3fb8af;
}

ul#ticker01 li span {
    color:#3fb8af;
}
/* News Ticker */
/*----------------------------------
 *          review
 ----------------------------------*/

/*----------------------------------
 *          end review
 ----------------------------------*/
.fixed {
width:1012px;
margin:0 auto;
-webkit-box-shadow: 0px 0px 5px 0px rgba(0, 0, 0, 0.2);
-moz-box-shadow: 0px 0px 5px 0px rgba(0, 0, 0, 0.2);
box-shadow: 0px 0px 5px 0px rgba(0, 0, 0, 0.2);
margin-bottom:20px;
background:#fff;
}
    #navigation {
	width: 1012px !important;
    }

#full_bg {
position:fixed;
left:0;
top:0;
z-index:-1;
min-width:100%;
min-height:100%;
}
 
@media only screen and (min-width: 768px) and (max-width: 989px) {
    .fixed, #navigation {
        width: 681px !important;
    }
}
@media only screen and (min-width: 480px) and (max-width: 767px) {
       .fixed, #navigation {
        width: 470px !important;
       }
}
@media only screen and (min-width: 320px) and (max-width: 479px) {
        .fixed, #navigation {
        width: 310px !important;
       }
}



 
@media only screen and (min-width: 768px) and (max-width: 989px) {
    }
@media only screen and (min-width: 480px) and (max-width: 767px) {
       
}
@media only screen and (min-width: 320px) and (max-width: 479px) {
       }

</style></head>
<body>
                    <div class="fixed">
	<div id="header_wrap">
<div id="top" class="top_bar">
    <div class="inner">
     			     			                    <div class="mobileTopMenu_wrap">
       </div>
          
        	       <ul class="top_social_icons">
                    <li class="twitter"><a href="http://twitter.com/northvalley">twitter</a></li>
        
                <li class="facebook"><a href="http://www.facebook.com/northvalleymagazine">facebook</a></li>        
        
        
        
                             <li class="rss"><a href="http://www.northvalleymagazine.com/feed/">rss</a></li>
        
        
        
        

        
        
        
        
    </ul>
	    </div> <!--End Inner-->
</div> <!--End Topbar-->

<header id="header">
    <div class="top_line"></div>
<div class="inner">
    <div class="logo">
<a href="http://www.northvalleymagazine.com">
		<img src="http://www.northvalleymagazine.com/wp-content/uploads/2013/03/logo4.png" alt="North Valley Magazine" />
	</a>
    </div> <!--End Logo-->
                     <div class="top_ad">
                                      <a href="https://www.spectrumretirement.com/senior-living/az/chandler/gardens-at-ocotillo-senior-living/"><img src="http://www.northvalleymagazine.com/wp-content/uploads/2016/10/gardens_at_ocotillo468_60.jpg" alt=""></a>
                               </div> <!--End Top Ad-->
        </div> <!--Inner-->
</header> <!--End Header-->
	</div> <!--End Header Wrap-->
<nav id="navigation">
    <div class="nav_wrap">
    <div class="inner">
     			     <ul id="menu-main-menu" class="nav"><li id="menu-item-52" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-52"><a href="http://www.northvalleymagazine.com/">Home</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46"><a href="http://www.northvalleymagazine.com/about/">About</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="http://www.northvalleymagazine.com/contact-us/">Contact Us</a></li>
<li id="menu-item-2768" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2768"><a href="http://www.northvalleymagazine.com/category/blog/">Blog</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="http://www.northvalleymagazine.com/events/">Events</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50"><a href="http://www.northvalleymagazine.com/advertise/">Advertise</a></li>
<li id="menu-item-49" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49"><a href="http://www.northvalleymagazine.com/file-upload/">File Upload</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51"><a href="http://www.northvalleymagazine.com/subscribe/">Subscribe</a></li>
<li id="menu-item-2279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2279"><a href="http://www.northvalleymagazine.com/digital-edition/">Digital Edition</a></li>
</ul>			      <div id="mobile_menu_secondary" class="menu-main-menu-container"><select class="mobileMainMenu" id="mobileMainMenu" name="mobileMainMenu" onchange="location.href = document.getElementById('mobileMainMenu').value;"><option value="http://www.northvalleymagazine.com/" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-52">Home</option><option value="http://www.northvalleymagazine.com/about/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46">About</option><option value="http://www.northvalleymagazine.com/contact-us/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47">Contact Us</option><option value="http://www.northvalleymagazine.com/category/blog/" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2768">Blog</option><option value="http://www.northvalleymagazine.com/events/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48">Events</option><option value="http://www.northvalleymagazine.com/advertise/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50">Advertise</option><option value="http://www.northvalleymagazine.com/file-upload/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49">File Upload</option><option value="http://www.northvalleymagazine.com/subscribe/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51">Subscribe</option><option value="http://www.northvalleymagazine.com/digital-edition/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2279">Digital Edition</option></select></div>    
   </div> <!--Inner-->
    </div> <!--End Nav Wrap-->
</nav> <!--End Navigation-->
    <div class="inner">
    <div class="container">
    <div class="main">
		<div class="box_outer">
    <article class="cat_article">
        <h1 class="cat_article_title">Timeless Turmeric</h1>
 	    <div class="article_meta">
 	       <span class="meta_author">Posted by: <a href="http://www.northvalleymagazine.com/author/tmahrle/" title="Posts by North Valley" rel="author">North Valley</a></span>
		       <span class="meta_date">Posted date:  <strong>November 25, 2018</strong></span>
       
	       <span class="meta_cat">In:  <strong><a href="http://www.northvalleymagazine.com/category/blog/" rel="category tag">Blog</a>, <a href="http://www.northvalleymagazine.com/category/dining/" rel="category tag">Dining</a></strong></span>
		       <span class="meta_sap">|</span> <span class="meta_comments">comment : <a href="http://www.northvalleymagazine.com/timeless-turmeric/#respond">0</a></span>
           </div> <!--article meta-->
	    <div id="article_content" class="single_article_content">
   				            	    <div style="text-align:center; margin-bottom:30px;">
                <img src="http://www.northvalleymagazine.com/wp-content/themes/goodnews4/framework/scripts/timthumb.php?src=http://www.northvalleymagazine.com/wp-content/uploads/2018/10/Screen-Shot-2018-10-22-at-2.19.15-PM.png&amp;h=275&amp;w=599&amp;zc=1" alt="Timeless Turmeric" title="Timeless Turmeric" />
	    </div>
        		        <p><strong>Ancient spice has modern benefits</strong></p>
<p><span style="font-weight: 400;">By Angela Shelf Medearis</span></p>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">Turmeric has spiced up the news over the past few years. It’s a unique ingredient with an ancient history. Turmeric is thought to have originated in India over 5,000 years ago. It’s also a common ingredient in Chinese medicine and the centerpiece of Ayurveda, a traditional Indian medicine. </span></p>
<p><span style="font-weight: 400;">The spice is present in nearly every Indian curry dish, and its flavor is best described as earthy. Indians also use turmeric in pre-wedding rituals and apply it to their faces as a mask. Marco Polo was introduced to turmeric on his journey to China in 1280. Since then, it’s been hailed as the poor man’s saffron. However, the only thing the spices have in common is their bright color. </span></p>
<p><span style="font-weight: 400;">Turmeric is the rhizome, or underground stem of a ginger-like plant. The root’s flesh has an intense orange color that becomes yellow when dried. Turmeric gives ballpark mustard its bright yellow shade and also is used as a textile dye. </span></p>
<p><span style="font-weight: 400;">Curcumin, the compound responsible for turmeric’s vibrant yellow pigment, is believed to have anti-inflammatory, anticancer and antioxidant properties, according to early findings from animal and lab studies. It’s often used as a natural remedy for joint pain. It’s also well known for its antiseptic properties and is commonly applied to wounds.</span></p>
<p><span style="font-weight: 400;">Research shows turmeric may be effective for relieving an upset stomach and for reducing osteoarthritis pain. In some studies, the effectiveness of the spice compared favorably with that reported for pharmaceuticals, according to a National Institutes of Health report.</span></p>
<p><span style="font-weight: 400;">“Turmeric’s benefits are attributed to its anti-inflammatory and antioxidant action,” says Dr. Pam Duitsman, nutrition and health education specialist with University of Missouri Extension. “The best news is that turmeric is a spice that can accomplish its health-promoting work with virtually no adverse side effects. It is easy to reap the health benefits of turmeric by cooking with it, rather than taking it as a supplement.”</span></p>
<p><span style="font-weight: 400;">I’ve enjoyed finding ways to use this beautiful golden spice in my daily recipes. I love the intense color and flavors that result when I add a half teaspoon of turmeric and some lemon pepper to my scrambled eggs. No matter what the weather looks like outside, it’s always sunny in my kitchen! I’ve also added turmeric to the variety of spices I mix together to season meats and vegetables. </span></p>
<p><span style="font-weight: 400;">Use turmeric sparingly, as it can impart a medicinal flavor to food when used in large quantities. That’s why some chefs warn that you should “see it but not taste it.”</span></p>
<p><span style="font-weight: 400;">Typically, most recipes recommend combining turmeric with black pepper. Black pepper contains a compound called piperine, which inhibits the metabolic breakdown of turmeric in the gut and the liver. This allows higher levels of turmeric compounds to remain in the body (i.e., it increases its bioavailability), which may increase the effects of turmeric. However, it also can affect the breakdown of other compounds, including certain drugs. If you’re unsure about how combining turmeric and black pepper will affect your prescription medicines, consult your doctor.</span></p>
<p><span style="font-weight: 400;">Turmeric is the star of this spice blend and adds a burst of flavor to my recipe for spiced golden milk. You also may want to add a half teaspoon of turmeric spice blend to recipes for vinaigrettes, pizza dough, rice dishes, eggs and egg salad, sauteed vegetables, lentils, soups and smoothies.</span></p>
<p><strong>Turmeric spice blend</strong></p>
<p><span style="font-weight: 400;">2 </span> <span style="font-weight: 400;">tablespoons turmeric</span></p>
<p><span style="font-weight: 400;">2 </span> <span style="font-weight: 400;">teaspoons ground cardamom</span></p>
<p><span style="font-weight: 400;">2 </span> <span style="font-weight: 400;">teaspoons ground ginger</span></p>
<p><span style="font-weight: 400;">2 </span> <span style="font-weight: 400;">teaspoons black pepper</span></p>
<p><span style="font-weight: 400;">1 </span> <span style="font-weight: 400;">teaspoon cinnamon</span></p>
<p><span style="font-weight: 400;">1 </span> <span style="font-weight: 400;">teaspoon ground nutmeg</span></p>
<p><span style="font-weight: 400;">Combine ingredients in a jar. Cover tightly and shake before using. Keep in a cool, dark place. Makes about a half cup.</span></p>
<p><span style="font-weight: 400;">Spiced golden milk</span></p>
<p><span style="font-weight: 400;">Drinking spiced golden milk before going to bed can help relieve joint pain and induce sleep. </span></p>
<p><span style="font-weight: 400;">1 </span> <span style="font-weight: 400;">cup water</span></p>
<p><span style="font-weight: 400;">2 </span> <span style="font-weight: 400;">tablespoons turmeric spice blend</span></p>
<p><span style="font-weight: 400;">1 </span> <span style="font-weight: 400;">cup unsweetened non-dairy milk, preferably coconut milk or almond milk</span></p>
<p><span style="font-weight: 400;">1 </span> <span style="font-weight: 400;">tablespoon honey, agave syrup </span></p>
<p><span style="font-weight: 400;">or Stevia</span></p>
<p><span style="font-weight: 400;">1 </span> <span style="font-weight: 400;">tablespoon virgin coconut oil</span></p>
<p><span style="font-weight: 400;">Place water in a medium saucepan over high heat. Whisk in turmeric spice blend and stir until the mixture is well combined, about 2 to 3 minutes. Add coconut or almond milk, honey and coconut oil to the turmeric mixture in the saucepan. Bring to a low boil. Reduce heat to low and simmer, stirring occasionally, until flavors have melded, about 6 to 7 minutes. </span></p>
<p><span style="font-weight: 400;">Golden milk can be made up to 5 days ahead of time. Allow the milk to cool, store it in an airtight glass container and keep it refrigerated. Shake the milk to combine, and warm before serving. Makes two cups. </span></p>
<p><span style="font-weight: 400;">Angela Shelf Medearis is an award-winning children’s author, culinary historian and the author of seven cookbooks. Her new cookbook is The Kitchen Diva’s Diabetic Cookbook. Her website is <a href="http://www.divapro.com">www.divapro.com</a>.</span></p>
		<div class="clear"></div>
	 
    </div> <!--Single Article content-->
		
        <div class="single_share">
		                    <div class="single_sh_twitter sh_item">
                <a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.northvalleymagazine.com/timeless-turmeric/" data-count="vertical" data-lang="en">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
            </div> <!--Twitter Button-->

		            <div class="single_sh_gplus sh_item">
<!-- Place this tag where you want the +1 button to render -->
<div class="g-plusone" data-size="tall" data-href="http://www.northvalleymagazine.com/timeless-turmeric/"></div>
    </div> <!--google plus Button-->
    
            <div class="single_sh_facebook sh_item">
                <iframe src="//www.facebook.com/plugins/like.php?locale=en_US&href=http://www.northvalleymagazine.com/timeless-turmeric/&amp;send=false&amp;layout=box_count&amp;width=48&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=62" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:48px; height:62px;" allowTransparency="true"></iframe>
            </div> <!--facebook Button-->

            <div class="single_sh_facebook sh_item">
<a name="fb_share" type="box_count" expr:share_url='http://www.northvalleymagazine.com/timeless-turmeric/' href="http://www.facebook.com/sharer.php">Share</a><script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script>
            </div> <!--facebook Button-->


            <div class="single_sh_linkedin sh_item">
<script src="http://platform.linkedin.com/in.js" type="text/javascript"></script>
<script type="IN/Share" data-url="http://www.northvalleymagazine.com/timeless-turmeric/" data-counter="top"></script>
	    </div> <!--linkedin Button-->

            <div class="single_sh_su sh_item">
<!-- Place this tag where you want the su badge to render -->
<su:badge layout="5" location="http://www.northvalleymagazine.com/timeless-turmeric/"></su:badge>

<!-- Place this snippet wherever appropriate --> 
 <script type="text/javascript"> 
 (function() { 
     var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true; 
      li.src = 'https://platform.stumbleupon.com/1/widgets.js'; 
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s); 
 })(); 
 </script>
	    </div> <!--stumbleupon Button-->



    </div> <!--single Share-->		
    <div class="dots"></div>
     	    <div class="articles_nav">
        <span class="prev_article"><a href="http://www.northvalleymagazine.com/spin-rate/" rel="prev"><span>&#8249;</span> Previous</a></span>
        <span class="next_article"> </span>
    </div> <!--Articles Nav-->
         		        <h4 class="related_box_title">Related posts</h4>
    <div class="related_box">
	<ul class="default">
    	                       <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/spin-rate/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2018/10/61912782_s-150x150-126x91.jpg"  alt="Spin Rate" title="Spin Rate" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/spin-rate/">Spin Rate</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/daisy-chain-2/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2018/10/IMG_7114-1-150x150-126x91.jpg"  alt="Daisy Chain" title="Daisy Chain" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/daisy-chain-2/">Daisy Chain</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/on-a-roll/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2018/10/Copy-of-IMG_9747-150x150-126x91.jpg"  alt="On a Roll" title="On a Roll" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/on-a-roll/">On a Roll</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/home-sweat-home/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2018/10/50925816_s-150x150-126x91.jpg"  alt="Home Sweat Home" title="Home Sweat Home" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/home-sweat-home/">Home Sweat Home</a></h3>

    </li>
     <!--End Related Style-->
                                                 
	         	    	</ul>
    </div> <!--Related Box-->
     <!--Related Enable-->

<!-- You can start editing here. -->
<div id="comments">

	

</div>
	<div id="respond">

		<h4 id="respond-title">
			Leave a Comment        </h4>
	
				<p>You must be <a href="http://www.northvalleymagazine.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.northvalleymagazine.com%2Ftimeless-turmeric%2F">logged in</a> to post a comment.</p>
			</div>

        </article> <!--End Single Article-->
	</div><!--Box outer-->
        </div> <!--End Main-->
        <aside class="sidebar">
	 	                 <div class="box_outer dfp-ad-widget-class"><div class="widget"><!-- NVM-300x250-Top -->		<div id="ad_pos_nvm-300x250-top"
		     class="ad_pos_nvm-300x250-top NVM-300x250-Top dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('ad_pos_nvm-300x250-top');
				});
			</script>
		</div>
		</div></div><div class="box_outer widget_text"><div class="widget"><h3 class="widget_title">Submit a Story Tip</h3><div class="wid_border"></div>			<div class="textwidget"><p>Have a story tip or startup we should know about? <a href="http://www.northvalleymagazine.com/contact-us/">Send it our way!</a></p>
</div>
		</div></div><div class="box_outer widget_text"><div class="widget">			<div class="textwidget"><iframe src="//www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fnorthvalleymagazine&amp;width=300&amp;height=290&amp;show_faces=true&amp;colorscheme=light&amp;stream=false&amp;border_color=%23ffffff&amp;header=true&amp;appId=247750225361604" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100%; height:290px;" allowTransparency="true"></iframe></div>
		</div></div><div class="box_outer dfp-ad-widget-class"><div class="widget"><!-- NVM-300x250-Middle -->		<div id="ad_pos_nvm-300x250-middle"
		     class="ad_pos_nvm-300x250-middle NVM-300x250-Middle dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('ad_pos_nvm-300x250-middle');
				});
			</script>
		</div>
		</div></div><div class="box_outer widget_reallysimpletwitterwidget"><div class="widget"><h3 class="widget_title"><a href="http://twitter.com/northvalley" class="twitter_title_link" >Latest Tweets</a></h3><div class="wid_border"></div>
      <ul class="really_simple_twitter_widget"><li>Have a happy and safe Thanksgiving! <a href="https://t.co/OLxBBdKzLj" class="twitter-link" >https://t.co/OLxBBdKzLj</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2018/11/22 15:03">Nov 22</span></li><li>Spin Rate: the continuation of my series titled “Fundamentals for a Better Game.” 
<a href="https://t.co/Mq9YJ8h7bQ" class="twitter-link" >https://t.co/Mq9YJ8h7bQ</a> <a href="https://t.co/K70rUNhzo5" class="twitter-link" >https://t.co/K70rUNhzo5</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2018/11/22 02:19">Nov 22</span></li><li>Flower Child opens fourth Arizona location at Desert Ridge
<a href="https://t.co/J75GeMr6xM" class="twitter-link" >https://t.co/J75GeMr6xM</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2018/11/19 16:30">Nov 19</span></li></ul></div></div><div class="box_outer dfp-ad-widget-class"><div class="widget"><!-- NVM-300x250-Bottom -->		<div id="ad_pos_nvm-300x250-bottom"
		     class="ad_pos_nvm-300x250-bottom NVM-300x250-Bottom dfp_ad_pos">
			<script type='text/javascript'>
				googletag.cmd.push(function () {
					googletag.display('ad_pos_nvm-300x250-bottom');
				});
			</script>
		</div>
		</div></div>	            </aside> <!--End Sidebar-->
            </div> <!--End Container-->
  </div> <!--End Inner-->
<footer id="footer">
    <div class="footer_wrap">
        <div class="foot_border"></div>
    <div class="inner">
 	     			<div class="one_fourth">
			        			</div>
			<div class="one_fourth">
			        			</div>
			<div class="one_fourth">
			        			</div>
			<div class="one_fourth last">
			        			</div>
	        </div> <!--End Inner-->
    </div> <!--footer wrap-->
</footer> <!--End Footer-->
<div class="bottom_bar">
    <div class="inner">

        	     			     <ul id="menu-footer-menu" class="footer_menu"><li id="menu-item-91" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91"><a href="http://www.northvalleymagazine.com/terms/">Terms</a></li>
</ul>			         <p class="copyrights">© 2018 North Valley Magazine

</p>
    </div> <!--End Inner-->
</div> <!--end bottom Bar-->
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/custom.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.northvalleymagazine.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/builder/js_composer/assets/js_composer_front.js?ver=3.3.3'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
</div> <!--End Fixed-->
<div class="scrollTo_top">
    <a title="Scroll to top" href="#">
    	    <img src="http://www.northvalleymagazine.com/wp-content/themes/goodnews4/images/up.png" alt="Scroll to top">
        </a>
</div>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-1998484-18']);
  _gaq.push(['_setDomainName', '.northvalleymagazine.com']);
  _gaq.push(['_trackPageview']);

  (function() {
	var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
	ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
	var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script> 
</body>
</html>
