<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>

<meta charset="UTF-8" />

<meta name="description" content="Phoenix Independence Day Celebrations––2017   July 1 Businesses in Cave Creek are teaming up for the Fourth on the First, featuring live music from Redneck Revolution and The Saints of Las Vegas, a kids’ splash area, mechanical bull riding, food and beverages, shopping, and fireworks, which begin at 9 p.m. Free. 4 p.m. to 11:30 [&#8230;]" />
<meta name="keywords" content="4th of July,Fourth of July,Independence Day Celebrations," /><!--End Meta Tags For SEO-->
<meta property="og:title" content="Fourth of July Celebrations"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/"/>
<meta property="og:image" content="http://www.northvalleymagazine.com/wp-content/uploads/2017/06/Screen-Shot-2017-06-28-at-5.25.11-PM-440x1024.jpg"/>
<meta property="og:description" content="Phoenix Independence Day Celebrations––2017   July 1 Businesses in Cave Creek are teaming up for the Fourth on the First, featuring live music from Redneck Revolution and The Saints of Las Vegas, a kids’ splash area, mechanical bull riding, food and beverages, shopping, and fireworks, which begin at 9 p.m. Free. 4 p.m. to 11:30 [&#8230;]"/>
<meta property="og:site_name" content="North Valley Magazine"/>
	<link rel="stylesheet" type="text/css" href="http://www.northvalleymagazine.com/wp-content/themes/goodnews4/style.css" />

 
<link href='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/responsive.css' rel='stylesheet' type='text/css'>
<link href='http://fonts.googleapis.com/css?family=Play:400,700' rel='stylesheet' type='text/css'>
<!-- Custom favicon -->
<link rel="shortcut icon" href="http://www.northvalleymagazine.com/wp-content/uploads/2013/03/n-favicon.png" />

<!-- feeds, pingback -->
  <link rel="alternate" type="application/rss+xml" title="North Valley Magazine RSS Feed" href="http://www.northvalleymagazine.com/feed/" />
  <link rel="pingback" href="http://www.northvalleymagazine.com/xmlrpc.php" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

<!-- This site is optimized with the Yoast SEO plugin v2.3.5 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Fourth of July Celebrations</title>
<link rel="canonical" href="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Fourth of July Celebrations" />
<meta property="og:description" content="Phoenix Independence Day Celebrations––2017   July 1 Businesses in Cave Creek are teaming up for the Fourth on the First, featuring live music from Redneck Revolution and The Saints of Las Vegas, a kids’ splash area, mechanical bull riding, food and beverages, shopping, and fireworks, which begin at 9 p.m. Free. 4 p.m. to 11:30 &hellip;" />
<meta property="og:url" content="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/" />
<meta property="og:site_name" content="North Valley Magazine" />
<meta property="article:tag" content="4th of July" />
<meta property="article:tag" content="Fourth of July" />
<meta property="article:tag" content="Independence Day Celebrations" />
<meta property="article:section" content="Blog" />
<meta property="article:published_time" content="2017-06-29T00:24:12+00:00" />
<meta property="article:modified_time" content="2017-06-29T00:33:05+00:00" />
<meta property="og:updated_time" content="2017-06-29T00:33:05+00:00" />
<meta property="og:image" content="http://www.northvalleymagazine.com/wp-content/uploads/2017/06/Screen-Shot-2017-06-28-at-5.25.11-PM.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="North Valley Magazine &raquo; Fourth of July Celebrations 2017 Comments Feed" href="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.northvalleymagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='options_typography_-css'  href='http://fonts.googleapis.com/css?family=' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_georgia-css'  href='http://fonts.googleapis.com/css?family=georgia' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/builder/js_composer/assets/bootstrap/css/bootstrap.css?ver=3.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/builder/js_composer/assets/css/js_composer_front.css?ver=3.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='DOPTS_JScrollPaneStyle-css'  href='http://www.northvalleymagazine.com/wp-content/plugins/dopts/libraries/gui/css/jquery.jscrollpane.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='DOPTS_ThumbnailScrollerStyle-css'  href='http://www.northvalleymagazine.com/wp-content/plugins/dopts/assets/gui/css/jquery.dop.ThumbnailScroller.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='default-template-css'  href='http://www.northvalleymagazine.com/wp-content/plugins/really-simple-twitter-feed-widget/extension/readygraph/assets/css/default-popup.css?ver=4.8' type='text/css' media='all' />
<!-- This site uses the Google Analytics by Yoast plugin v5.4.6 - Universal enabled - https://yoast.com/wordpress/plugins/google-analytics/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-66735939-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by Yoast -->
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.cycle.all.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.tools.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.cookie.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.jplayer.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/effects.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.tweet.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.prettyPhoto.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.tipsy.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.fitvids.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/jquery.li-scroller.1.0.js?ver=4.8'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.9.2/jquery-ui.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/plugins/dopts/assets/js/jquery.dop.ThumbnailScroller.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='http://www.northvalleymagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.northvalleymagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.northvalleymagazine.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8" />
<link rel='shortlink' href='http://www.northvalleymagazine.com/?p=2697' />
<link rel="alternate" type="application/json+oembed" href="http://www.northvalleymagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.northvalleymagazine.com%2Ffourth-of-july-celebrations-2017%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.northvalleymagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.northvalleymagazine.com%2Ffourth-of-july-celebrations-2017%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.16 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-2 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


    <!--[if lt IE 9]>
<script src="http://ie7-js.googlecode.com/svn/version/2.1(beta4)/IE9.js"></script>
<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

      <script type="text/javascript" src="http://maps.google.com/maps/api/js?sensor=false"></script>
<!-- Place this render call where appropriate -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
 <style type="text/css">
body {
background-repeat:repeat;
background-attachment: scroll;
 
font-size:14px;
font-weight: Normal;
}
a:hover, .cat_article_content .article_read_more, a.nb_recent_more, .tweet_list li a:hover, .news_box .recent_news_content span a:hover, .article_meta a:hover {
color:#3FB8AF;
}

.single_article_content h1 {
font-size:36px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h2 {
font-size:30px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h3 {
font-size:24px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h4 {
font-size:18px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h5 {
font-size:14px;
font-weight: Normal;
font-family:georgia;
}

.single_article_content h6 {
font-size:12px;
font-weight: Normal;
font-family:georgia;
}

/*----------------------------------
 *          Main font
 ----------------------------------*/
#navigation ul.nav > li a , .slider_items .slider_caption h2, .slider_items .slider_caption h2 a, .lates_video_news .widget_title, .news_box .news_box_heading h2, .sidebar .widget .widget_title, .sidebar .widget input.sb, #footer .widget .widget_title, .cat_title, .tabbed_widget ul.tabbed_nav li a, .mom_social_counter .sc_item .social_box span, ul#ticker01 li a, #crumbs {
font-family: !important;
}
/*******************************************************************
 *      Colors Start Here 
 *****************************************************************/
/*    Alert Bar   */
.top_alert {
background-repeat:no-repeat;
background-attachment: scroll;
 
}
/*    Topbar & bottombar     */
.top_bar, .top_bar ul.top_nav li ul, .bottom_bar {
background-color:#3FB8AF;
box-shadow: 0 0px 0px 0 #3C4048 inset;
background-repeat:no-repeat;
background-attachment: scroll;
 
}
.top_bar ul.top_nav li a, .bottom_bar a, .bottom_bar p.copyrights {
color:#000000;
}
/*  Header  */
#header {
background-repeat:repeat;
background-attachment: scroll;
 
}

/*      Navigation      */
#navigation .nav_wrap {
background-repeat:repeat;
background-attachment: scroll;
 
}
#navigation ul.nav li:hover > a, #navigation ul.nav > li.current-menu-item > a, #navigation ul.nav > li.current-menu-ancestor > a, #navigation ul.nav li.home:hover > a, #navigation ul.nav > li.home.current-menu-item > a, #navigation ul.nav > li.home.current-menu-ancestor > a {
color:#000000;
}
#navigation ul.nav li:hover > a, #navigation ul.nav > li.current-menu-item > a, #navigation ul.nav > li.current-menu-ancestor > a, #navigation ul.nav li.home:hover > a, #navigation ul.nav > li.home.current-menu-item > a, #navigation ul.nav > li.home.current-menu-ancestor > a,  #navigation ul.nav li ul li {
background-color:#3FB8AF;
}
#navigation ul.nav li ul li a:hover {
color:;
background-repeat:repeat;
background-attachment: scroll;
 
}
/*     Feature      */
/*     Widgets  */
.sidebar .widget, .lates_video_news, .news_box, .cat_article, .ticker_widget, .news_boxes_tabs {
}
.sidebar .widget .widget_title, .lates_video_news .widget_title, .news_boxes_tabs ul.custom_tabs {
}
/*  NewsBox */

/* News Ticker */
.ticker_widget {
}
ul#ticker01 li a {
color:#40454d;
font-size:14px;
font-weight: Normal;
}
ul#ticker01 li a:hover {
    color:#3fb8af;
}

ul#ticker01 li span {
    color:#3fb8af;
}
/* News Ticker */
/*----------------------------------
 *          review
 ----------------------------------*/

/*----------------------------------
 *          end review
 ----------------------------------*/
.fixed {
width:1012px;
margin:0 auto;
-webkit-box-shadow: 0px 0px 5px 0px rgba(0, 0, 0, 0.2);
-moz-box-shadow: 0px 0px 5px 0px rgba(0, 0, 0, 0.2);
box-shadow: 0px 0px 5px 0px rgba(0, 0, 0, 0.2);
margin-bottom:20px;
background:#fff;
}
    #navigation {
	width: 1012px !important;
    }

#full_bg {
position:fixed;
left:0;
top:0;
z-index:-1;
min-width:100%;
min-height:100%;
}
 
@media only screen and (min-width: 768px) and (max-width: 989px) {
    .fixed, #navigation {
        width: 681px !important;
    }
}
@media only screen and (min-width: 480px) and (max-width: 767px) {
       .fixed, #navigation {
        width: 470px !important;
       }
}
@media only screen and (min-width: 320px) and (max-width: 479px) {
        .fixed, #navigation {
        width: 310px !important;
       }
}



 
@media only screen and (min-width: 768px) and (max-width: 989px) {
    }
@media only screen and (min-width: 480px) and (max-width: 767px) {
       
}
@media only screen and (min-width: 320px) and (max-width: 479px) {
       }

</style></head>
<body>
                    <div class="fixed">
	<div id="header_wrap">
<div id="top" class="top_bar">
    <div class="inner">
     			     <ul id="menu-top-nav" class="top_nav"><li id="menu-item-131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131"><a href="http://www.northvalleymagazine.com/featured-north-valley-companies/">Featured North Valley Companies</a></li>
</ul>			                    <div class="mobileTopMenu_wrap">
  <div id="mobile_top_menu_secondary" class="menu-top-nav-container"><select class="mobileTopMenu" id="mobileTopMenu" name="mobileTopMenu" onchange="location.href = document.getElementById('mobileTopMenu').value;"><option value="http://www.northvalleymagazine.com/featured-north-valley-companies/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131">Featured North Valley Companies</option></select></div>     </div>
          
        	       <ul class="top_social_icons">
                    <li class="twitter"><a href="http://twitter.com/northvalley">twitter</a></li>
        
                <li class="facebook"><a href="http://www.facebook.com/northvalleymagazine">facebook</a></li>        
        
        
        
                             <li class="rss"><a href="http://www.northvalleymagazine.com/feed/">rss</a></li>
        
        
        
        

        
        
        
        
    </ul>
	    </div> <!--End Inner-->
</div> <!--End Topbar-->

<header id="header">
    <div class="top_line"></div>
<div class="inner">
    <div class="logo">
<a href="http://www.northvalleymagazine.com">
		<img src="http://www.northvalleymagazine.com/wp-content/uploads/2013/03/logo4.png" alt="North Valley Magazine" />
	</a>
    </div> <!--End Logo-->
                     <div class="top_ad">
                                      <a href="https://www.spectrumretirement.com/senior-living/az/chandler/gardens-at-ocotillo-senior-living/"><img src="http://www.northvalleymagazine.com/wp-content/uploads/2016/10/gardens_at_ocotillo468_60.jpg" alt=""></a>
                               </div> <!--End Top Ad-->
        </div> <!--Inner-->
</header> <!--End Header-->
	</div> <!--End Header Wrap-->
<nav id="navigation">
    <div class="nav_wrap">
    <div class="inner">
     			     <ul id="menu-main-menu" class="nav"><li id="menu-item-52" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-52"><a href="http://www.northvalleymagazine.com/">Home</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46"><a href="http://www.northvalleymagazine.com/about/">About</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="http://www.northvalleymagazine.com/contact-us/">Contact Us</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="http://www.northvalleymagazine.com/events/">Events</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-134"><a href="http://www.northvalleymagazine.com/category/blog/">Blog</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50"><a href="http://www.northvalleymagazine.com/advertise/">Advertise</a></li>
<li id="menu-item-49" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49"><a href="http://www.northvalleymagazine.com/file-upload/">File Upload</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51"><a href="http://www.northvalleymagazine.com/subscribe/">Subscribe</a></li>
<li id="menu-item-2279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2279"><a href="http://www.northvalleymagazine.com/digital-edition/">Digital Edition</a></li>
</ul>			      <div id="mobile_menu_secondary" class="menu-main-menu-container"><select class="mobileMainMenu" id="mobileMainMenu" name="mobileMainMenu" onchange="location.href = document.getElementById('mobileMainMenu').value;"><option value="http://www.northvalleymagazine.com/" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-52">Home</option><option value="http://www.northvalleymagazine.com/about/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46">About</option><option value="http://www.northvalleymagazine.com/contact-us/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47">Contact Us</option><option value="http://www.northvalleymagazine.com/events/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48">Events</option><option value="http://www.northvalleymagazine.com/category/blog/" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-134">Blog</option><option value="http://www.northvalleymagazine.com/advertise/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50">Advertise</option><option value="http://www.northvalleymagazine.com/file-upload/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49">File Upload</option><option value="http://www.northvalleymagazine.com/subscribe/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51">Subscribe</option><option value="http://www.northvalleymagazine.com/digital-edition/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2279">Digital Edition</option></select></div>    
   </div> <!--Inner-->
    </div> <!--End Nav Wrap-->
</nav> <!--End Navigation-->
    <div class="inner">
    <div class="box_outer nt_bd">
    <div class="ticker_widget">
	<div class="news_ticker">
	    <div class="right_arrow"></div>
	<ul id="ticker01">
                    	<li><ahref="https://issuu.com/northvalley/docs/nv0217">Check out our </li>
<li><span>&raquo;</span>June  '17 / July  '17 issue!</a></li>
<li><span>&raquo;</span><a href="https://www.facebook.com/northvalleymagazine" target="_blank">Have you liked us on Facebook yet?</a></li>		</ul>
	</div><!--News Ticker-->
    </div> <!--End Widget-->
    </div> <!--box outer-->

</div> <!--End Inner-->
<div class="inner">
    <div class="container">
    <div class="main">
		<div class="box_outer">
    <article class="cat_article">
        <h1 class="cat_article_title">Fourth of July Celebrations 2017</h1>
 	    <div class="article_meta">
 	       <span class="meta_author">Posted by: <a href="http://www.northvalleymagazine.com/author/sondra-barr/" title="Posts by Sondra Barr" rel="author">Sondra Barr</a></span>
		       <span class="meta_date">Posted date:  <strong>June 29, 2017</strong></span>
       
	       <span class="meta_cat">In:  <strong><a href="http://www.northvalleymagazine.com/category/blog/" rel="category tag">Blog</a>, <a href="http://www.northvalleymagazine.com/category/events/" rel="category tag">Events</a></strong></span>
		       <span class="meta_sap">|</span> <span class="meta_comments">comment : <a href="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/#respond">0</a></span>
           </div> <!--article meta-->
	    <div id="article_content" class="single_article_content">
   					        <p><strong>Phoenix Independence Day Celebrations––2017</strong></p>
<p><strong> </strong></p>
<p><strong>July 1</strong></p>
<p>Businesses in Cave Creek are teaming up for the <strong>Fourth on the First</strong>, featuring live music from Redneck Revolution and The Saints of Las Vegas, a kids’ splash area, mechanical bull riding, food and beverages, shopping, and fireworks, which begin at 9 p.m. Free. 4 p.m. to 11:30 p.m. Frontier Town, 6245 E. Cave Creek Rd., Cave Creek. <strong>frontiertownaz.com</strong></p>
<p>&nbsp;</p>
<p><strong>July 3</strong></p>
<p>Sponsored by Harold’s Corral and The Buffalo Chip Saloon, a <strong>Fireworks Extravaganza</strong> is one of the largest fireworks displays in the Valley and includes live music, kids’ activities, and food and drink specials. Free. 5:30 p.m. to midnight. Harold’s Corral, 6895 E. Cave Creek Rd., Cave Creek. <strong>haroldscorral.com</strong></p>
<p>&nbsp;</p>
<p><strong>July 3</strong></p>
<p>Anthem celebrates its<strong> 18<sup>th</sup> Annual Independence Day Celebration. </strong>The popular event includes wet and dry rides, inflatables, food vendors, a DJ/dancing, fireworks, and more. 6 p.m. to 10 p.m. in the Anthem Community Park. Purchase ride/bounce wristbands in advance at the community center.</p>
<p>&nbsp;</p>
<p><strong>July 4</strong></p>
<p>Be red, white, and cool at <strong>Scottsdale 4<sup>th</sup> of July Celebration</strong>. It’s a cool family friendly patriotic wonderland indoors at WestWorld, expanded to the entire 300,000 square-foot fully air-conditioned Tony Nelssen Equestrian Center. This year’s celebration includes a BMX show, bull riding rodeo, pony rides, all-star stunt dogs challenge, fireworks, and more. General admission, $12. Scottsdale residents, $6. Fireworks only, $20 per car. 3 p.m. to 9:30 p.m. WestWorld, 16601 N. Pima Rd., Scottsdale. scottsdale4th.com</p>
<p>&nbsp;</p>
<p><strong>July 4</strong></p>
<p>Head to <strong>Fourth at the Fountain</strong> for music, games, and prizes. DJ Steve Grosse will keep the family moving and grooving with great tunes throughout the night. This year, a new event format will be introduced and has been designed to be a community wide event open to all. Free. 6 p.m. to 10 pm. Fireworks display at 9 p.m. Fountain Park, 12925 N. Saguaro Blvd., Fountain Hills. <strong>experiencefountainhills.com</strong></p>
<p>&nbsp;</p>
<p><strong>July 4</strong></p>
<p>Get patriotic at <strong>Chandler’s Fourth of July Fireworks Spectacular</strong>. The celebration includes food and fireworks. $5 per vehicle. 5 p.m. to 10:30 p.m. Fireworks begin at 9 p.m. Tumbleweed Park, 2250 S. McQueen Rd., Chandler. chandleraz.gov</p>
		<div class="clear"></div>
	 
    </div> <!--Single Article content-->
		
        <div class="single_share">
		                    <div class="single_sh_twitter sh_item">
                <a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/" data-count="vertical" data-lang="en">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
            </div> <!--Twitter Button-->

		            <div class="single_sh_gplus sh_item">
<!-- Place this tag where you want the +1 button to render -->
<div class="g-plusone" data-size="tall" data-href="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/"></div>
    </div> <!--google plus Button-->
    
            <div class="single_sh_facebook sh_item">
                <iframe src="//www.facebook.com/plugins/like.php?locale=en_US&href=http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/&amp;send=false&amp;layout=box_count&amp;width=48&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=62" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:48px; height:62px;" allowTransparency="true"></iframe>
            </div> <!--facebook Button-->

            <div class="single_sh_facebook sh_item">
<a name="fb_share" type="box_count" expr:share_url='http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/' href="http://www.facebook.com/sharer.php">Share</a><script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script>
            </div> <!--facebook Button-->


            <div class="single_sh_linkedin sh_item">
<script src="http://platform.linkedin.com/in.js" type="text/javascript"></script>
<script type="IN/Share" data-url="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/" data-counter="top"></script>
	    </div> <!--linkedin Button-->

            <div class="single_sh_su sh_item">
<!-- Place this tag where you want the su badge to render -->
<su:badge layout="5" location="http://www.northvalleymagazine.com/fourth-of-july-celebrations-2017/"></su:badge>

<!-- Place this snippet wherever appropriate --> 
 <script type="text/javascript"> 
 (function() { 
     var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true; 
      li.src = 'https://platform.stumbleupon.com/1/widgets.js'; 
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s); 
 })(); 
 </script>
	    </div> <!--stumbleupon Button-->



    </div> <!--single Share-->		
    <div class="dots"></div>
     	    <div class="articles_nav">
        <span class="prev_article"><a href="http://www.northvalleymagazine.com/lon-megargee-arizonas-first-cowboy-artist-was-a-creative-character/" rel="prev"><span>&#8249;</span> Previous</a></span>
        <span class="next_article"> </span>
    </div> <!--Articles Nav-->
         	    <h4 class="author_box_title">About The Author</h4>
    <div class="author_box">
	<img alt='' src='http://1.gravatar.com/avatar/15e554dd34b2dbff26867a4c9b89258c?s=67&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/15e554dd34b2dbff26867a4c9b89258c?s=134&amp;d=mm&amp;r=g 2x' class='avatar avatar-67 photo' height='67' width='67' />    <div class="author_details">
        <h5 class="author_name"><a href="http://www.northvalleymagazine.com/author/sondra-barr/" title="Posts by Sondra Barr" rel="author">Sondra Barr</a></h5>
        <h5 class="author_title">
                    </h5>
        <p>
           A Scottsdale native, Sondra Barr is a journalist, editor, marketing, and social media sort. She writes for local and national publications and enjoys penning stories on interesting people, places, and things. You can view her work at www.themediabarr.com.        </p>
    </div> <!--Author Details-->
    <div class="author_info">
        <span class="num_of_entry">Number of Entries :
        305</span>
        <div class="author_connect">
            	   	  		        </div>
    </div> <!--Author Info-->
    </div> <!--Author Box-->
    	        <h4 class="related_box_title">Related posts</h4>
    <div class="related_box">
	<ul class="default">
    	                       <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/lon-megargee-arizonas-first-cowboy-artist-was-a-creative-character/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2017/06/NV-History-June-July-17-150x150-126x91.jpg"  alt="Lon Megargee: Arizona’s first cowboy artist was a creative character" title="Lon Megargee: Arizona’s first cowboy artist was a creative character" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/lon-megargee-arizonas-first-cowboy-artist-was-a-creative-character/">Lon Megargee: Arizona’s first cowboy artist was a creative character</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/how-white-is-white/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2017/06/NV-Gems-June-July-17-150x150-126x91.jpg"  alt="How White is White?" title="How White is White?" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/how-white-is-white/">How White is White?</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/fresh-reads-for-june/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2017/06/NV-Reads-June-July-17-150x150-126x91.jpg"  alt="Fresh reads for June" title="Fresh reads for June" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/fresh-reads-for-june/">Fresh reads for June</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
		    	<div class="related_image">
		<a href="http://www.northvalleymagazine.com/going-for-gold-two-local-teens-awarded-girl-scouts-highest-honor/">
   	    		            		    			<img src="http://www.northvalleymagazine.com/wp-content/uploads/2017/06/NV-Faces-June-July-17-150x150-126x91.jpg"  alt="Going for Gold: Two local teens awarded Girl Scouts&#8217; highest honor" title="Going for Gold: Two local teens awarded Girl Scouts&#8217; highest honor" />
		    		
		</a>

	</div> <!--Related Image-->
		
             <h3><a href="http://www.northvalleymagazine.com/going-for-gold-two-local-teens-awarded-girl-scouts-highest-honor/">Going for Gold: Two local teens awarded Girl Scouts&#8217; highest honor</a></h3>

    </li>
     <!--End Related Style-->
                                                 
	         	    	</ul>
    </div> <!--Related Box-->
     <!--Related Enable-->

<!-- You can start editing here. -->
<div id="comments">

	

</div>
	<div id="respond">

		<h4 id="respond-title">
			Leave a Comment        </h4>
	
				<p>You must be <a href="http://www.northvalleymagazine.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.northvalleymagazine.com%2Ffourth-of-july-celebrations-2017%2F">logged in</a> to post a comment.</p>
			</div>

        </article> <!--End Single Article-->
	</div><!--Box outer-->
        </div> <!--End Main-->
        <aside class="sidebar">
	 	                 <div class="box_outer widget_text"><div class="widget"><h3 class="widget_title">Our Sponsers</h3><div class="wid_border"></div>			<div class="textwidget"><!-- Either there are no banners, they are disabled or none qualified for this location! -->	</div>
		</div></div>		   	    <div class="custom_textwidget">
				<div id="aweber-form">

<h5>SUBSCRIBE TO OUR NEWSLETTER</h5>

<p style="color:#666;">   Subscribe to Our Free Newsletter and Be the First to Hear about Upcoming Events and Special Offers!</p>

<!-- AWeber Web Form Generator 3.0 -->
<form method="post" class="af-form-wrapper" action="http://www.aweber.com/scripts/addlead.pl"  >
<div style="display: none;">
<input type="hidden" name="meta_web_form_id" value="585705485" />
<input type="hidden" name="meta_split_id" value="" />
<input type="hidden" name="listname" value="northvalleymag" />
<input type="hidden" name="redirect" value="http://www.aweber.com/thankyou-coi.htm?m=text" id="redirect_d1757258d215c692d00ed62b16bfefd4" />

<input type="hidden" name="meta_adtracking" value="NVM" />
<input type="hidden" name="meta_message" value="1" />
<input type="hidden" name="meta_required" value="email" />

<input type="hidden" name="meta_tooltip" value="email||Email Address..." />
</div>

<div id="af-form-991502069" class="af-form"><div id="af-body-991502069"  class="af-body af-standards">

<div class="af-element">
<div class="af-textWrap"><input class="text" id="awf_field-30817847" type="text" name="email" value="Email Address..." tabindex="500"  onfocus=" if (this.value == 'Email Address...') { this.value = ''; }" onblur="if (this.value == '') { this.value='Email Address...';} " />
</div><div class="af-clear"></div>
</div>

<div class="buttonContainer">
<input name="submit" type="image"  alt="Submit Form" src="http://www.blogtrepreneur.com/images/subscribe-button.png" />

</div>

</div>
</div>
<div style="display: none;"><img src="http://forms.aweber.com/form/displays.htm?id=jCycrOzsLKxsDA==" alt="" /></div>
</form>
<script type="text/javascript">
    <!--
    (function() {
        var IE = /*@cc_on!@*/false;
        if (!IE) { return; }
        if (document.compatMode && document.compatMode == 'BackCompat') {
            if (document.getElementById("af-form-991502069")) {
                document.getElementById("af-form-991502069").className = 'af-form af-quirksMode';
            }
            if (document.getElementById("af-body-991502069")) {
                document.getElementById("af-body-991502069").className = "af-body inline af-quirksMode";
            }
            if (document.getElementById("af-header-991502069")) {
                document.getElementById("af-header-991502069").className = "af-header af-quirksMode";
            }
            if (document.getElementById("af-footer-991502069")) {
                document.getElementById("af-footer-991502069").className = "af-footer af-quirksMode";
            }
        }
    })();
    -->
</script>

<!-- /AWeber Web Form Generator 3.0 -->

<br /><br />
<h5>SUBMIT A STORY TIP: </h5>

Have a story tip or startup we should know about?
<a href="contact-us">Send it our way!</a>


</div><!-- /#aweber-form -->
			  </div>

			
<div class="box_outer widget_text"><div class="widget">			<div class="textwidget"><iframe src="//www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fnorthvalleymagazine&amp;width=300&amp;height=290&amp;show_faces=true&amp;colorscheme=light&amp;stream=false&amp;border_color=%23ffffff&amp;header=true&amp;appId=247750225361604" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:290px;" allowTransparency="true"></iframe></div>
		</div></div><div class="box_outer widget_reallysimpletwitterwidget"><div class="widget"><h3 class="widget_title"><a href="http://twitter.com/northvalley" class="twitter_title_link" >Latest Tweets</a></h3><div class="wid_border"></div>
      <ul class="really_simple_twitter_widget"><li>TONIGHT! Join <a href="http://twitter.com/shopdesertridge" class="twitter-user" >@shopdesertridge</a> for weekly summer splash fun each Tuesday. Visit <a href="https://t.co/n8gsJKXG8v" class="twitter-link" >https://t.co/n8gsJKXG8v</a> for details… <a href="https://t.co/kuPLLxXtvn" class="twitter-link" >https://t.co/kuPLLxXtvn</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2017/06/27 18:57">Jun 27</span></li><li>The June '17 Cover of our annual Top <a href="http://twitter.com/#!/search?q=%23Realtor" class="twitter-link" >#Realtor</a> Issue - Real Estate Agent <a href="http://twitter.com/SperoPagos" class="twitter-user" >@SperoPagos</a> <a href="http://twitter.com/#!/search?q=%23realestate" class="twitter-link" >#realestate</a> <a href="http://twitter.com/#!/search?q=%23northvalley" class="twitter-link" >#northvalley</a>… <a href="https://t.co/yryBRzVHgP" class="twitter-link" >https://t.co/yryBRzVHgP</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2017/06/22 22:18">Jun 22</span></li><li>Last chance! Nominate by tagging a <a href="http://twitter.com/#!/search?q=%23Dad" class="twitter-link" >#Dad</a> on @shopdesertridge's Facebook page: <a href="https://t.co/L3AkbOFw9l" class="twitter-link" >https://t.co/L3AkbOFw9l</a> to win ultimat… <a href="https://t.co/6RWavAMYh7" class="twitter-link" >https://t.co/6RWavAMYh7</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2017/06/15 19:13">Jun 15</span></li></ul></div></div>	            </aside> <!--End Sidebar-->
            </div> <!--End Container-->
  </div> <!--End Inner-->
<footer id="footer">
    <div class="footer_wrap">
        <div class="foot_border"></div>
    <div class="inner">
 	     			<div class="one_fourth">
			        			</div>
			<div class="one_fourth">
			        			</div>
			<div class="one_fourth">
			        			</div>
			<div class="one_fourth last">
			        			</div>
	        </div> <!--End Inner-->
    </div> <!--footer wrap-->
</footer> <!--End Footer-->
<div class="bottom_bar">
    <div class="inner">

        	     			     <ul id="menu-footer-menu" class="footer_menu"><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92"><a href="http://www.northvalleymagazine.com/writers-agreement/">Writers Agreement</a></li>
<li id="menu-item-91" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91"><a href="http://www.northvalleymagazine.com/terms/">Terms</a></li>
<li id="menu-item-1095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1095"><a href="http://www.northvalleymagazine.com/contestrules/">North Valley Magazine Contest Rules</a></li>
</ul>			         <p class="copyrights">© 2015 North Valley Magazine

</p>
    </div> <!--End Inner-->
</div> <!--end bottom Bar-->
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/js/custom.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.northvalleymagazine.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-content/themes/goodnews4/builder/js_composer/assets/js_composer_front.js?ver=3.3.3'></script>
<script type='text/javascript' src='http://www.northvalleymagazine.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
</div> <!--End Fixed-->
<div class="scrollTo_top">
    <a title="Scroll to top" href="#">
    	    <img src="http://www.northvalleymagazine.com/wp-content/themes/goodnews4/images/up.png" alt="Scroll to top">
        </a>
</div>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-1998484-18']);
  _gaq.push(['_setDomainName', '.northvalleymagazine.com']);
  _gaq.push(['_trackPageview']);

  (function() {
	var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
	ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
	var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script> 
</body>
</html>
